Unhandled Exception

Oct 11, 2011 at 7:29 AM

Tried to use the file browser on my unlocked MOZART. The program connects properly to the phone but starting
the file browser brings up dozens of pop-ups:

Unhandled Exception...
Uh. Oh. Something bad happened. Exception: System.Windows.Markup.XamlParserException...

The phone is unlocked and active. Mango 7720.
After that I have to reboot my PC (Win7SP1, 64-Bit) because it's not possible to close the app or the
pop-ups.

Any idea?

Coordinator
Oct 11, 2011 at 8:23 AM

One other user complained about the cascading, never ending exceptions, but couldn't get a repro that I could use to track the problem down and fix it.

If this happens again to you, please try to get a screenshot. In the meanwhile I'm going to add some code to protect against this case (it's horrible that you have to restart your computer because of this app!) - I'll push it out later today.

Thanks!

Coordinator
Oct 11, 2011 at 9:58 AM

I've pushed version 1.3.2 which should solve the flooding. If you do see the exception again please log a bug with a screenshot under the "Issue Tracker" tab above.

Thanks!

Oct 11, 2011 at 1:05 PM

Thank you.

I've installed the V 1.3.2 and tried to open the filebrowser.

The program connects to the phone but opening the browser leads to popups again.

I've attached a screenshot – there are only TWO of these popups now and I can close the

program afterwards with the taskmanager – re-booting isn't necessary.

Mathias

Von: nachmore [email removed]
Gesendet: Dienstag, 11. Oktober 2011 10:59
An: nosphera2@gmx.net
Betreff: Re: Unhandled Exception [wptools:275398]

From: nachmore

I've pushed version 1.3.2 which should solve the flooding. If you do see the exception again please log a bug with a screenshot under the "Issue Tracker" tab above.

Thanks!

Coordinator
Oct 11, 2011 at 2:16 PM

The screenshot seems to have been dropped off :(

I'm happy to hear that it at least stops after 2 messages (that's the new design) but it would be great to solve this properly. If you could create a new issue (http://wptools.codeplex.com/WorkItem/Create) and attach the screenshot to there I could run with it from there.

Thanks again!